Dell Inspiron Mini 10 – Faulty memory and Windows 7 install

This is the first Notebook repair on my blog, and it’s a fairly interesting one. A little bit of back story:

The owner of the notebook sent it off to Dell to replace the memory. That might sound silly, sending it all the way to Dell for a simple memory upgrade but there’s nothing simple about this Dell Mini 10! To upgrade the memory you need to remove the battery, keyboard, all the screws on the bottom, the top case, unplug every cable from the motherboard, unscrew the motherboard and turn it over. So basically you have to dismantle the ENTIRE unit just to get to the memory.

The netbook went off and was returned, but not quite in the condition it was sent. One of the screws was missing from the bottom and the palm rest was visibly cracked. Not off to a good start, but at least the memory had been upgraded.

However almost immediately it started having problems, blue screen memory dumps being the most prominent. A call to Dell resulted in them telling the owner to restore it to factory defaults… quite why they didn’t first recommend a memory test is beyond me (there’s one built in to the Netbook, easily accessible from the boot menu!).

During the restore procedure the Netbook crashed, on reboot it gave the error message “Bootmgr.exe missing” and wouldn’t get any further. Hats off to Dell for the outstanding advice.

I picked the netbook up from the owner and he went through the above with me, so I was keen to do the best I could. He passed on the original 1gb ram (the Netbook had been upgraded to 2gb) so I could see if that worked any better.

On getting it home I decided the best thing to do would be to check the hard-drive and try and get Windows 7 back on. The drive was fairly easily accessible and, after removing it, scanned with next to no errors.

I put the drive back in to the Netbook and tried a restore, unfortunately I had no luck there. The Windows 7 disc tried to repair start-up but failed each time. Using bootrec.exe also failed, it seemed the install was incomplete. Because of the bootmgr error I also couldn’t boot up the Dell recovery partition and restore that way.

In the end I connected the hard-drive to my computer and booted off a Windows 7 install disc I had hanging around. I got to the command prompt and used ImageX to copy the Dell Windows Image (from the Recovery partition) over to the C drive. That gave us a proper install of Windows 7 on C, but the boot information still wasn’t correct. I then restarted, booted off the Windows 7 disc again and used Bootrec to fix the booting errors.

At last the laptop booted in to Windows 7, and it looked like it was working fine! After setting up an initial user account it started to boot up properly and then crashed with a blue screen. Not a good sign.

I created another user account (just to be sure) and this time it got to the desktop. However as soon as it booted up explorer.exe started crashing…repeatedly. It would launch, then crash and the start bar would vanish, then it would launch and crash again.

It was clearly the memory, there was little else it could be but I thought I’d best make sure.

I booted up the netbook and loaded the diagnostics utility and started the memory test. It failed within 3 seconds! So out came the screwdriver and apart came the netbook.

image

I took extra care on the palm rest as it had been visibly strained the last time it was opened and I didn’t want it to snap, fortunately after taking my time it came off fine.

image

After unplugging pretty much everything I finally got to the RAM and compared the two. The original memory is:

1gb 2Rx16 PC2-6400S-666-12

the new memory is:

2gb 2Rx8 PC2-5300S-555-12

image

The 2Rx16/8 bit isn’t important. It relates to the ‘density’ of the memory. However the 6400s and the 5300s can be, it relates to the ‘speed’ of the memory.
Some motherboards are picky about what they’ll accept (Apple products especially so) and it looks like this Dell is too, either that or the DIMM is just faulty.

I replaced the 2gb DIMM with the original 1gb DIMM and put it all back together. I booted it up and ran the memory test, no problems. I then booted in to Windows 7 and it ran absolutely fine.

Success, and a big thumbs down to Dell!

My Fee: £25
Parts: £0

Total: £25

(Which Dell should really foot the bill for)

Leave a Comment